易语言的文件夹循环读取

作者: jiukeshuju 分类: 易语言 发布时间: 2020-02-22 14:07

 

 

 

 

 

 

 

 

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击

列表框1.清空 ()

搜寻文件 (驱动器框1.驱动器 + “:”, 编辑框1.内容)

.子程序 __启动窗口_创建完毕

.子程序 搜寻文件
.参数 目录名, 文本型
.参数 文件名, 文本型, 可空
.局部变量 结果, 文本型

‘ 先找文件
.如果真 (文件名 = “”) ‘ 如果文件名为空,则搜索所有
文件名 = “*.*”
.如果真结束
.如果真 (取文本右边 (目录名, 1) ≠ “\”) ‘ 如果目录名 abc 不存在 \ 则 abc\ 加上\
目录名 = 目录名 + “\”
.如果真结束
结果 = 寻找文件 (目录名 + 文件名, ) ‘ 寻找文件

‘ 再找目录
.判断循环首 (结果 ≠ “”)
列表框1.加入项目 (目录名 + 结果, )
结果 = 寻找文件 (, )
.判断循环尾 ()
结果 = 寻找文件 (目录名 + “*.*”, #子目录)
‘ 列表框1.加入项目 (结果, )

.判断循环首 (结果 ≠ “”)
.如果真 (结果 ≠ “.” 且 结果 ≠ “..”)
搜寻文件 (目录名 + 结果, 文件名)
处理事件 ()

.如果真结束

结果 = 寻找文件 (, #子目录)

.判断循环尾 ()

.子程序 __启动窗口_托盘事件
.参数 操作类型, 整数型

.子程序 __启动窗口_鼠标右键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

弹出菜单 (弹出菜单, , )

 

 

如果觉得我的文章对您有用,请随意赞赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注