卷帘式菜单和拖放控件的案例

作者: jiukeshuju 分类: 易语言 发布时间: 2020-03-12 08:23

‘ 判断后缀 快捷方式取目标图片, 新建图片数组, 提取加入图片, 合并图片数组, 加入项目, 置项目提示文本

.版本 2
.支持库 edroptarget
.支持库 iext3
.支持库 iext2
.支持库 eAPI

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (卷帘式菜单1.取窗口句柄 ())
卷帘式菜单1.项目图标图片组 = 建空图片组 (32, 32)

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型
.局部变量 图片组数据变量, 字节集

‘ 判断得到文件的后缀名是不是快捷方式,如果是则取快捷方式目标
.如果真 (取文本右边 (接收到的文件路径, 4) = “.lnk”)
接收到的文件路径 = 取快捷方式目标 (接收到的文件路径, , , , , , , )
.如果真结束

图片组数据变量 = 建空图片组 (32, 32)
提取加入图片 (图片组数据变量, 接收到的文件路径, , 假)

卷帘式菜单1.项目图标图片组 = 合并图片组 (卷帘式菜单1.项目图标图片组, 图片组数据变量)
卷帘式菜单1.加入项目 (接收到的文件路径, , , 取图片组图片数 (卷帘式菜单1.项目图标图片组) - 1, )
卷帘式菜单1.置项目提示文本 (卷帘式菜单1.现行选中菜单, 卷帘式菜单1.取项目数 (卷帘式菜单1.现行选中菜单) - 1, 接收到的文件路径)

.子程序 _卷帘式菜单1_项目被双击
.参数 菜单索引, 整数型
.参数 项目索引, 整数型
.局部变量 文件路径, 文本型

文件路径 = 卷帘式菜单1.取项目提示文本 (菜单索引, 项目索引)

运行 (文件路径, 假, )

如果觉得我的文章对您有用,请随意赞赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注